Jump to content


A Raymond Weil W1


3 replies to this topic

#1 OFFLINE   Zimmer

    Automatic

  • Member
  • 109 posts
  • Joined 15-March 10

Posted 17 March 2010 - 11:58 AM

Hi,was given this watch a few days ago. It's a Raymond Weil W1, and it's got 6800 on the back.
After googling, I can't find anywhere a W1 with a "white face", saw a black one and a lime green one, but never a white one. It came in a tall metal tin.
Anyone know if it's old or new or anything about this model. Also have no instructions, but I presume the left hand dial should reset to Zero, but I can't get it to. It will only go to either side of zero. All the manuals I can download from the RW site, the chronograph instructions show models with 3 chrono dials.
Anyone have one of these.

Posted Image

Edited by Zimmer, 17 March 2010 - 11:59 AM.


#2 OFFLINE   rdwiow

    Chronograph

  • Member
  • 1,338 posts
  • Joined 15-August 08
  • Gender:Male
  • Location:The Sunny South of England

Posted 17 March 2010 - 12:10 PM

This watch has the Swiss ISA movement, dont know the number of it. Try googling ISA chronograph movemnet it may be of help. From memory to reset the hand position you need to do a combination of button pushes to enter the reset mode.
Some of the early models had a recessed corrector at the 8 oclock position, pushing this entered
the reset mode.
Good luck

#3 OFFLINE   Zimmer

    Automatic

  • Member
  • 109 posts
  • Joined 15-March 10

Posted 17 March 2010 - 01:58 PM

I can enter reset mode by pulling out the crown all the way. Then pressing the two pushers together for a few seconds enters reset mode, the top pusher moves the large hand, and the bottom pusher moves the hand of the left hand dial to the zero position. All happy so far, but I can't exit reset mode, except by depressing the two pushers together. When I do that the hand on the left hand dial, jumps by one, and ends up like in photo. I must be doing something wrong.

#4 OFFLINE   Zimmer

    Automatic

  • Member
  • 109 posts
  • Joined 15-March 10

Posted 17 March 2010 - 05:02 PM

Thanks, syncing the chrono is sorted, it was my own stupidity, I was trying to sync the 30 minute counter in the wrong place doh.

Still haven't found one like it on any place on the net, hope it's "genuine".





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users